large number of interrupts when using ffmpeg

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

large number of interrupts when using ffmpeg

Daniel Dimitrov
Hello all,
I have super micro server which i use to transcode some live streams,
everything worked perfectly since i had to add 2 new stream (total 6
streams) and then interruption in most of the streams appeared.My system is
:

#CentOS Linux release 8.2.2004 (Core)
# nproc
16
#2 x Intel Corporation I210 Gigabit Network Connection
#gigabit switch

I have noticed a large number of interrupts occupying only one core,please
take a look at the attached pictures and let me know if there is a way to
tune any parameters in such a way to distribute the interrupts.I have tried
with *ethtool -L eno2 combined 4* and this partly did the job but
after executing the command i started loose packages from all my
streams.FFmpeg version:

ffmpeg version 4.3.1-static https://johnvansickle.com/ffmpeg/  Copyright
(c) 2000-2020 the FFmpeg developers
  built with gcc 8 (Debian 8.3.0-6)
  configuration: --enable-gpl --enable-version3 --enable-static
--disable-debug --disable-ffplay --disable-indev=sndio
--disable-outdev=sndio --cc=gcc --enable-fontconfig --enable-frei0r
--enable-gnutls --enable-gmp --enable-libgme --enable-gray --enable-libaom
--enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype
--enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb
--enable-libopenjpeg --enable-librubberband --enable-libsoxr
--enable-libspeex --enable-libsrt --enable-libvorbis --enable-libopus
--enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc
--enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265
--enable-libxml2 --enable-libdav1d --enable-libxvid --enable-libzvbi
--enable-libzimg

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

stm.png (117K) Download Attachment
stm2.png (242K) Download Attachment