Quantcast

install problem of the libavutil.so.50 kind

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

install problem of the libavutil.so.50 kind

Jim Shupert, Jr.
Friends,
I am attempting an install of ffmpeg on centOS 5.3

I am using as a guide the wisdom found here  
http://www.wowtutorial.org/tutorial/224.html


of course,  I have a problem  , after making if I enter  ffmpeg -h , or , ffmpeg -formats
ffmpeg
ffmpeg: error while loading shared libraries: libavutil.so.50: cannot open
shared object file: No such file or directory

I find this -- which I thought humorus
http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2006-August/014121.html

and this which seems to make some sense
http://linux.justinhartman.com/Talk:FFmpeg,_FFmpeg-PHP,_Lame,_Libogg,_Libvorbis,_FLVtool2,_Mplayer,_Mencoder,_AMR_Installation#ffmpeg:_error_while_loading_shared_libraries:_libavutil.so.50

suggested is

ln -s /usr/local/lib/libavutil.so.50 /usr/lib/libavutil.so.50

ln -s /usr/local/lib/libswscale.so.0 /usr/lib/libswscale.so.0

ln -s /usr/local/lib/libtheora.so.0 /usr/lib/libtheora.so.0

so is that making links ? and do ya'll think that would fix me?

and there is this
I have a  libswscale.so.0  ( yippie )

but no libavutil.so.50    ( darn )

i do have
  /usr/lib/libavutil.so.49       60.5 KB   that is a link to a shared lib
 /usr/lib/libavutil.so.49.15.0  60.5 KB   that is a a shared lib

I do not have  libtheora.so.0

so any suggestions would be welcomed.


just for reference my config Options are

./configure --enable-libmp3lame --enable-libtheora --enable-libvorbis
--enable-libfaac --enable-libfaad --disable-mmx --enable-shared
--enable-libxvid --enable-gpl --enable-nonfree

Thanks!

jS
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: install problem of the libavutil.so.50 kind

Ismael Valladolid Torres
On Thu, Sep 17, 2009 at 1:18 AM, Jim Shupert <[hidden email]> wrote:
> ffmpeg: error while loading shared libraries: libavutil.so.50: cannot open
> shared object file: No such file or directory

For me, it made sense compiling having configured with
--prefix=/opt/ffmpeg. Then after make install everything goes into
/opt/ffmpeg and binaries at /opt/ffmpeg/bin find libraries at
/opt/ffmpeg/lib flawlessly. Far easier than tweaking with ldconfig or
LD_LIBRARY_PATH. Keep us updated!

Cordially, Ismael
--
Ismael Valladolid Torres      Hey there! ivalladt is using Twitter.
  <[hidden email]>        http://twitter.com/ivalladt

t. 0034912519850              Facebook: http://profile.to/ivalladt
m. 0034609884094 (Yoigo)                http://groups.to/lamediahostia

Google Talk/Jabber/MSN Messenger: [hidden email]
      Jaiku/Twitter/Skype/Yahoo!: ivalladt
                         AIM/ICQ: 264472328     GnuPG key: DE721AF4
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: install problem of the libavutil.so.50 kind

Jim Shupert, Jr.


Ismael Valladolid Torres wrote:

> On Thu, Sep 17, 2009 at 1:18 AM, Jim Shupert <[hidden email]> wrote:
>  
>> ffmpeg: error while loading shared libraries: libavutil.so.50: cannot open
>> shared object file: No such file or directory
>>    
>
> For me, it made sense compiling having configured with
> --prefix=/opt/ffmpeg. Then after make install everything goes into
> /opt/ffmpeg and binaries at /opt/ffmpeg/bin find libraries at
> /opt/ffmpeg/lib flawlessly. Far easier than tweaking with ldconfig or
> LD_LIBRARY_PATH. Keep us updated!
>
> Cordially, Ismael
>  

Thanks
Let me see if i understand what you are suggesting :
i should config with

.*/configure --enable-libmp3lame --enable-libtheora --enable-libvorbis
--enable-libfaac --enable-libfaad --disable-mmx --enable-shared
--enable-libxvid --enable-gpl --enable-nonfree --prefix=/opt/ffmpeg *

and that is it?
do I need to mkdir of opt?

and what about the fact ( i think ) that i do not have a
libavutil.so.50   found on my machine

i did a search and I find these
 /usr/lib/libavutil.so.49       60.5 KB   that is a link to a shared lib
 /usr/lib/libavutil.so.49.15.0  60.5 KB   that is a a shared lib

do I need to 'get'  libavutil.so.50

Thanks again -- i do appreciate your time & wisdom ( i only have time....)

best,
jS
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: install problem of the libavutil.so.50 kind

Jim Shupert, Jr.
In reply to this post by Jim Shupert, Jr.
good news..
i did a
n -s /usr/local/lib/libavutil.so.50 /usr/lib/libavutil.so.50
and now it works

if i do ffmpeg - h   ,i get the help
if i do ffmpeg
i get
FFmpeg version SVN-r19591, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  configuration: --enable-libmp3lame --enable-libtheora
--enable-libvorbis --enable-libfaac --enable-libfaad --disable-mmx
--enable-shared --enable-libxvid --enable-gpl
--enable-nonfree
  libavutil     50. 3. 0 / 50. 3. 0
  libavcodec    52.32. 0 / 52.32. 0
  libavformat   52.37. 0 / 52.37. 0
  libavdevice   52. 2. 0 / 52. 2. 0
  libswscale     0. 7. 1 /  0. 7. 1

so --- yippe
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Loading...