ffmpeg on Solaris 8

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ffmpeg on Solaris 8

Marcos Trejo Munguia
Hi,
 
I compiled ffmpeg on Solaris 8 (SunOS 5.8 Generic_117350-46 sun4u sparc SUNW,Sun-Fire-V440) with the following configuration:
 
./configure --disable-ffserver --disable-ffplay --disable-network --disable-vhook --disable-demuxer=mpc8 --disable-decoder=vorbis --disable-decoder=atrac3
 
I am able to convert avi, wmv and mpeg videos to flv but when I try to play the resulting flvs I get no video and the audio is very distortioned.
 
Anybody know what I did wrong or what should I do to make it work?
 
Thanks in advanced.
 
Cheers
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: ffmpeg on Solaris 8

VP Lists

On Feb 12, 2008, at 1:56 PM, Marcos Trejo Munguia wrote:

> I am able to convert avi, wmv and mpeg videos to flv but when I try  
> to play the resulting flvs I get no video and the audio is very  
> distortioned.
>
> Anybody know what I did wrong or what should I do to make it work?

Hi there.

Post the feedback you get from the output.  That will also have the  
information about your config.  Please be aware, people get chided  
easily in here, so post that information and review the docs, which  
might have missing information.

Cheers

Rich in Toronto

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: ffmpeg on Solaris 8

Marcos Trejo Munguia
In reply to this post by Marcos Trejo Munguia
Hi,

Following Rich's recommendation I'm attaching the output I get from running ffmpeg, now I am able to hear the audio after recompiling ffmpeg with --enable-libmp3lame but still no video at all.

$ ffmpeg -i ../test/clock.avi -ar 22050 -ab 56000 -b 300000 -r 12 -s 320x240 ../test/clock.flv
FFmpeg version SVN-r11902, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --disable-ffserver --disable-ffplay --disable-network --disable-vhook --disable-demuxer=mpc8 --disable-decoder=vorbis --disable-decoder=atrac3 --enable-libmp3lame --extra-cflags=-I/usr/local/ffmpeg/include --extra-ldflags=-L/usr/local/ffmpeg/lib --prefix=/usr/local/ffmpeg
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Feb 12 2008 19:00:29, gcc: 3.4.6
Input #0, avi, from '../test/clock.avi':
  Duration: 00:00:12.0, start: 0.000000, bitrate: 55 kb/s
    Stream #0.0: Video: msrle, pal8, 321x321 [PAR 0:1 DAR 0:1],  1.00 tb(r)
    Stream #0.1: Audio: truespeech, 8000 Hz, mono, 8 kb/s
PIX_FMT_YUV420P will be used as an intermediate format for rescaling
Output #0, flv, to '../test/clock.flv':
    Stream #0.0: Video: flv, yuv420p, 320x240 [PAR 0:1 DAR 0:1], q=2-31, 300 kb/s, 12.00 tb(c)
    Stream #0.1: Audio: libmp3lame, 22050 Hz, mono, 56 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
Press [q] to stop encoding
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5186 < 5188)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5242 < 5244)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5020 < 5022)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5388 < 5390)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5370 < 5372)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5566 < 5568)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5144 < 5146)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5378 < 5380)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5204 < 5206)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5980 < 5982)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (5818 < 5820)
[msrle @ 40a158] MS RLE: ended frame decode with bytes left over (6010 < 6012)
frame=  132 fps= 92 q=2.0 Lsize=     350kB time=11.0 bitrate= 260.3kbits/s
video:14kB audio:82kB global headers:0kB muxing overhead 260.605816%

I compiled the same version of ffmpeg on cygwin and everything works fine, the problem seems to be something related with Solaris (SunOS 5.8 Generic_117350-46 sun4u sparc SUNW,Sun-Fire-V440)

Thanks in advanced.

Cheers.

Date: Tue, 12 Feb 2008 15:33:44 -0500
From: Rich <[hidden email]>
Subject: Re: [Ffmpeg-user] ffmpeg on Solaris 8
To: FFmpeg user questions and RTFMs <[hidden email]>
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed


On Feb 12, 2008, at 1:56 PM, Marcos Trejo Munguia wrote:

> I am able to convert avi, wmv and mpeg videos to flv but when I try
> to play the resulting flvs I get no video and the audio is very
> distortioned.
>
> Anybody know what I did wrong or what should I do to make it work?

Hi there.

Post the feedback you get from the output.  That will also have the
information about your config.  Please be aware, people get chided
easily in here, so post that information and review the docs, which
might have missing information.

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user