Error Message: sps_id 1 out of range

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Error Message: sps_id 1 out of range

Simone Croci
Hi All,

I am decoding an MVC H.264 video and I get a lot of error messages "sps_id
1 out of range". What is the problem? is it caused by the fact that ffmpeg
does not support MVC H.264?

Regards,
Simon
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Error Message: sps_id 1 out of range

Carl Zwanzig
On 4/2/2021 2:55 PM, Simone Croci wrote:
> I am decoding an MVC H.264 video and I get a lot of error messages "sps_id
> 1 out of range". What is the problem? is it caused by the fact that ffmpeg
> does not support MVC H.264?

Please include the complete command and its complete output. If you aren't
using a very recent version (the "git head" if possible), try again with that.

z!
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Error Message: sps_id 1 out of range

Simone Croci
This is the command:

ffmpeg -i video.mkv -c:v copy -bsf:v h264_mp4toannexb -an -f h264
stream.h264


I am using ffmpeg that was built from the master branch on the 28th of
March 2021. I downloaded it from https://www.gyan.dev/ffmpeg/builds/.

Simone

On Sat, 3 Apr 2021 at 21:09, Carl Zwanzig <[hidden email]> wrote:

> On 4/2/2021 2:55 PM, Simone Croci wrote:
> > I am decoding an MVC H.264 video and I get a lot of error messages
> "sps_id
> > 1 out of range". What is the problem? is it caused by the fact that
> ffmpeg
> > does not support MVC H.264?
>
> Please include the complete command and its complete output. If you aren't
> using a very recent version (the "git head" if possible), try again with
> that.
>
> z!
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Error Message: sps_id 1 out of range

Carl Zwanzig
On 4/3/2021 1:18 PM, Simone Croci wrote:
> This is the command:

need the output (-always- include the output, in the email, not attached nor
linked to another site).

z!
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Error Message: sps_id 1 out of range

Simone Croci
On Sat, 3 Apr 2021 at 21:20, Carl Zwanzig <[hidden email]> wrote:

> On 4/3/2021 1:18 PM, Simone Croci wrote:
> > This is the command:
>
> need the output (-always- include the output, in the email, not attached
> nor
> linked to another site).
>

I have run again the command after restarting the computer, and I haven't
seen any error message this time.

This is the error message I got the first time I run the command:

[h264 @ 00000153dc5d4280] sps_id 1 out of range


Apparently, the problem has been solved by simply rebooting the PC. Btw, my
OS is Windows 10.

Simone


> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Error Message: sps_id 1 out of range

Carl Eugen Hoyos-2
In reply to this post by Simone Croci


> Am 02.04.2021 um 23:54 schrieb Simone Croci <[hidden email]>:
>
> I am decoding an MVC H.264 video and I get a lot of error messages "sps_id
> 1 out of range". What is the problem?


> is it caused by the fact that ffmpeg
> does not support MVC H.264?

Yes.

As Carl wrote:
When asking questions on this mailing list, always provide the command line you tested together with the complete, uncut console output, do not use external resources if possible.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".